Current Version plugins

Add-on Compatibility for Firefox 52

If you haven’t read it yet, please give our plans for 2017 a look. These updates are aimed mostly at add-ons using legacy APIs, but WebExtensions is the way forward.

Firefox 52 will be released on March 7th. Here’s the list of changes that went into this version that can affect add-on compatibility. There is more information available in Firefox 52 for Developers, so you should also give it a look.

General

XPCOM and Modules

Themes

Let me know in the comments if there’s anything missing or incorrect on these lists. If your add-on breaks on Firefox 52, I’d like to know.

The automatic compatibility validation and upgrade for add-ons on AMO will happen in a few weeks, so keep an eye on your email if you have an add-on listed on our site with its compatibility set to Firefox 51.


Leave a Comment

Your email address will not be published. Required fields are marked *

Menu Title